Monday, January 26, 2009

org.ajax4jsf.config.ParsingException: No filter mapping set for a filter

It goes something like this:


ERROR [[/WaSFP]] Exception starting filter richfaces
javax.servlet.ServletException: Error parse web application config

Caused by: org.ajax4jsf.config.ParsingException: No filter mapping set for a filter richfaces
at org.ajax4jsf.config.WebXMLParser.init(WebXMLParser.java:131)
at org.ajax4jsf.config.WebXMLParser.init(WebXMLParser.java:199)

It seemed strange, because I had defined a filter mapping and It worked for me before, so why not now? I had something like this in my web.xml:

<!-- Richfaces configuration-->
<context-param>
<param-name>org.richfaces.SKIN</param-name>
<param-value>blueSky</param-value>
</context-param>
<filter>
<display-name>RichFaces Filter</display-name>
<filter-name>richfaces</filter-name>
<filter-class>org.ajax4jsf.Filter</filter-class>
</filter>
<filter-mapping>
<filter-name>richfaces</filter-name>
<servlet-name>Faces Servlet</servlet-name>
<dispatcher>REQUEST</dispatcher>
<dispatcher>FORWARD</dispatcher>
<dispatcher>INCLUDE</dispatcher>
</filter-mapping>
<servlet>
<servlet-name>Faces Config</servlet-name> <!-- wrong, 'Faces Servlet' here-->
<servlet-class>javax.faces.webapp.FacesServlet</servlet-class>
<load-on-startup>1</load-on-startup>
</servlet>
<servlet-mapping>
<servlet-name>Faces Config</servlet-name> <!-- wrong again, 'Faces Servlet' here-->
<url-pattern>*.jsf</url-pattern>
</servlet-mapping>

Eclipse 3.4 with JBoss tools - Richfaces VPE 3.0.0 CR1. Nerver trust the IDE :)

2 comments:

mikom said...

Hi Alex.

I've got the same problem as you and I lost a half on hour over it. The problem is that you are trying map the richfaces filter to the 'Faces Servlet' servlet and you're JSF servlet is called 'Faces Config'.

You probably end up in this mess just like me after pasted some code. :)

Cheers,
Mihai.

Jean said...

Thanks - I did it too ;)